You are not logged in.

Dear visitor, welcome to Matix Forums. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

1

Sunday, June 19th 2016, 10:38pm

[1.10] Matix 1.6.5 Beta

Hello there,

here's an Update for Matix, this Version is for Minecraft 1.10.

To get help use "#help" in the Minecraft chat. To open the GUI press Right Shift.

If you want to change any keys, type "#key gui" into the chat.

If you have any questions while using Matix, you should install the IRC Plugin from here and ask for help on the IRC.

If you encounter any bugs, just reply to this thread or send me a private message.

Quoted


Changelog (1.6.5):

* [FEATURE] Add support for MCLeaks.net (Accessible on the AltManager)


"Changelog 1.6.4B"

Quoted


Changelog (1.6.4):

* [FEATURE] Add Dropdown Panel Element
* [TASK] Add UpdatePlayerMoveStateEvent (This is required for the new Follow Plugin)



"Changelog 1.6.3.2B"

Quoted


Changelog (1.6.3.2):

* [FEATURE] Add Strafe
* [BUGFIX] Fix rare crash when using NameTags



"Changelog 1.6.3.1B"

Quoted


Changelog (1.6.3.1):

* [TASK] Add distance slider to AntiFall
* [BUGFIX] Don't enable modules twice on startup
* [BUGFIX] Call onStartup for all modules, not just the ones with settings
* [BUGFIX] Continue loading external plugins even if one fails
* [BUGFIX] Call onStartup on new modules after reloading the client



"Changelog 1.6.3B"

Quoted


Changelog (1.6.3):

* [FEATURE] Add Module Settings panel when right clicking a module on the GUI (Modules with settings are marked with a tiny triangle)
* [FEATURE] Store enabled modules on client shutdown and enable them on startup
* [FEATURE] Add Nametags for bigger nametags (Replaces Healthtags)
* [FEATURE] Add super dank armor display to Nametags
* [FEATURE] Add setting command ("#setting get <setting key>"; "#setting set <setting key> <setting value>") <- I'll add a list sub-command soon
* [FEATURE] Add "#folder" command to open matix base folder
* [TASK] Display module description when hovering a module on the gui for over a second
* [TASK] Display help command output when using middle click on a module in the gui
* [TASK] Remove (now useless) Settings panel
* [TASK] Disable Keys when client.hidden is set
* [TASK] Add displayName to ValueBase
* [TASK] Don't scale nametags based on distance if the target entity is less than 10 blocks away
* [BUGFIX] Fix MiddleClick click registering
* [BUGFIX] Fix Xray and BlockESP block saving
* [BUGFIX] Load saved panel data after panels have been loaded
* [BUGFIX] Don't restore settings if module doesn't have any saved settings



Check the Repository for more Information regarding the Changes.

Documentation is available here (In Progress!)

>

Here's the download link, have fun!

Download 1.6.5B
Mirror 1.6.5B

2

Monday, June 20th 2016, 5:31pm

Where did you get the deobfuscation mappings for 1.10? I'm seeing a few 1.10 clients popping up but I can't seem to find MCP for 1.10 and Forge doesn't seem to be updated either!

EDIT: I forgot to say a few things. I'm really in a quite desperate need for an autoreconnect feature since I'm playing on this server that is always full with many people trying to join at all times.

This post has been edited 1 times, last edit by "inv41idu53rn4m3" (Jun 20th 2016, 5:36pm) with the following reason: Forgot to say a few things...


[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

3

Monday, June 20th 2016, 6:28pm

Where did you get the deobfuscation mappings for 1.10? I'm seeing a few 1.10 clients popping up but I can't seem to find MCP for 1.10 and Forge doesn't seem to be updated either!

EDIT: I forgot to say a few things. I'm really in a quite desperate need for an autoreconnect feature since I'm playing on this server that is always full with many people trying to join at all times.

You don't need the latest mappings. Most of 1.10 is similar to 1.9.4, you just won't have proper names for a few things, but that's not a real problem. You can either add those mappings yourself or just live with it, it's not super hard. :P

4

Tuesday, June 21st 2016, 1:01am

hey I am not able to get plugins anymore pls help

5

Tuesday, June 21st 2016, 1:48am

I get A bunch of errors

Exception in thread "main" java.lang.UnsupportedClassVersionError: net/minecraft/client/main/Main : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)

I am using linux mint as my operating system. Please help... (after launch it crash and I get the code above)

[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

6

Tuesday, June 21st 2016, 6:03am


I am using linux mint as my operating system. Please help... (after launch it crash and I get the code above)

You will need to update to Java 8.

hey I am not able to get plugins anymore pls help


Any Errors? Last time I tried that it worked perfectly. Did you install ChunkBorders?

7

Tuesday, June 21st 2016, 8:44am

Is there any way to get it to work on realms?

[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

8

Tuesday, June 21st 2016, 9:08am

Is there any way to get it to work on realms?

I don't think so. I could take a look at it though.

9

Tuesday, June 21st 2016, 9:30am

I don't think so. I could take a look at it though.
It doesn't come up with realms so i didn't think it would, but i mean could there be a way around it.

10

Tuesday, June 21st 2016, 1:48pm

I get same error as linux guy had
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/minecraft/client/main/Main : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)

i have java 8 still have problem

11

Tuesday, June 21st 2016, 1:55pm

Am never mind i figured it out :D sorry for double posting i needed to switch my minecraft launcher propertys he launched minecraft whit java 7 i switched to java 8 and all is good so far

12

Tuesday, June 21st 2016, 6:32pm

after you close the game and come back your installed plugins are uninstalled and u cant install it again.

NOTE:I DIDNT INSTALL CHUNKBORDERS

[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

13

Tuesday, June 21st 2016, 7:30pm

Quoted

after you close the game and come back your installed plugins are uninstalled and u cant install it again.

NOTE:I DIDNT INSTALL CHUNKBORDERS

I'll take a look at that once I get home.

14

Tuesday, June 21st 2016, 8:18pm

How to

How do I update openJDK (the thing that is used to open minecraft) would I just install java 8 of the website and would it work? Also you should teach me how to make a hacked client :D I am use to website coding... not hacked clients

[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

15

Tuesday, June 21st 2016, 8:28pm

How do I update openJDK (the thing that is used to open minecraft) would I just install java 8 of the website and would it work? Also you should teach me how to make a hacked client :D I am use to website coding... not hacked clients

Depending on how you installed it, you should be able to just uninstall openjdk7 and install openjdk8 using your package manager.


after you close the game and come back your installed plugins are uninstalled and u cant install it again.

NOTE:I DIDNT INSTALL CHUNKBORDERS

Can you please tell me which files you have in the following folder: ".minecraft\resourcepacks\1.10 R3D Craft 256x\modules"?

I just realized that Macros causes the same error as ChunkBorders. Make sure you delete the jar from the folder I just mentioned.

I'll work on a fix for both plugins now.

16

Tuesday, June 21st 2016, 8:56pm

thanks so much paxi :)
i realised that i installed macros! deleting it right now

17

Tuesday, June 21st 2016, 9:03pm

Healthtags don't seem to be working, and projectiles are glitched.
EDIT: Also, when I attempt to turn on my texture pack, the whole client crashes. This problem also happened in the 1.9 client.
(Crash Report : http://pastebin.com/uyZN607W )

And, when in the client, the icon in the windows taskbar just isn't there lol.



Also, do you think we could add the Chest ESP mod? That would be lovely <3
Using a hacker forums gives me a whole new vibe of cheaty lol.

I write sins not signatures.

This post has been edited 1 times, last edit by "Logan" (Jun 21st 2016, 9:08pm)


18

Tuesday, June 21st 2016, 9:07pm

deleted macros... still same error... i deleted the resourcepack... it worked!!! i quit... come back... same error... i think there is a problem with the irc plugin. i click install but it doesnt show that i installed it. i can still click install. when i click it says client was reloaded but i can still click install... :/

[Admin] Paxi

Matix Developer

  • "Paxi" started this thread

Posts: 178

Location: Germany

Occupation: Web Developer

  • Send private message

19

Tuesday, June 21st 2016, 9:10pm

deleted macros... still same error... i deleted the resourcepack... it worked!!! i quit... come back... same error... i think there is a problem with the irc plugin. i click install but it doesnt show that i installed it. i can still click install. when i click it says client was reloaded but i can still click install... :/

Oh yeah, you're right. I'll push an update within the next 30 minutes.

Thanks!

20

Tuesday, June 21st 2016, 9:11pm

deleted macros... still same error... i deleted the resourcepack... it worked!!! i quit... come back... same error... i think there is a problem with the irc plugin. i click install but it doesnt show that i installed it. i can still click install. when i click it says client was reloaded but i can still click install... :/

yeah... there is a problem with irc plugin! i deleted it and matix works like a charm now!

Similar threads